Tutorial HTTPS Hotspot Login MikroTik

Pada kesempatan kali ini saya akan memberikan sebuah tutorial https redirect di MikroTik. Saya berinisiatif memberikan tutorial ini karena saya sering menjumpai permasalahan ketika client mengakses hotspot yang seharusnya client masuk ke hotspot login, akan tetapi mereka tidak dapat masuk ke hotspot login dikarenakan client mengakses website https atau port 443 seperti google, youtube, facebook. Agar client bisa langsung masuk ke hotspot login saat mengakses website http maupun https, diperlukan CA certificate yang akan kita buat. Langsung saja ikuti tutorial dibawah ini.
Pertama
Buatlah CA certificate di MikroTik
/certificate add name="https-login-ca" common-name="https-login-ca" key-usage=key-cert-sign,crl-sign
Kedua 
Masuk ke MikroTik CA
/certificate sign https-login-ca
Ketiga
Buatlah regular certificate untuk https access
/certificate add name=login common-name=login
Keempat
masuk lagi ke certificate MikroTik CA
/certificate sign ca=https-login-ca login
Kelima
Masukkan mark certificate agar chrome, mozila atau web browser lainnya mendapatkan akses terpercaya dari web browsernya.
/certificate set trusted=yes https-login-ca
/certificate set trusted=yes login
Keenam
Menetapkan layanan https untuk certificate yang telah dibuat.
/ip service set www-ssl certificate=login

CATATAN: Saat pertama kali mengakses login page di komputer/laptop, ada peringatan tentang "This Connection is Untrusted" klik "I Understand the Risks" lalu klik "Add Exception" dan klik link hotspot login MikroTik anda.

Screen Shoot

Terminal MikroTik
Certificate yang telah dibuat
Konfigurasi Hotspot Server MikroTik
Hasil pengujian pada smartphone
Hasil akses dari komputer/laptop

SEMOGA BERMANFAAT
0 Komentar untuk "Tutorial HTTPS Hotspot Login MikroTik"

Back To Top